The Member Design EC3 application interface has been completely redesigned, with emphasis on ease of use, complete and immediate presentation of the various member and loading case data.

The pop-up dialog approach needed to access many of the member data has been replaced with a continuous property grid, where the detailing data is displayed in a hierarchical fashion that makes it easy to locate specific items. Another innovation is the ability to display many view windows of the selected member, each independent from the other, so that one can display the linked structure, while another can display the member in 3D, each with its own display angle and zoom level.

The environment displays various options in a main menu and also in a main toolbar. The main application window is displayed below and it has been organized in three main areas: On the left, the property pages area and on the right, the view windows area. At the lowest part of the application window, there is another property pages area and at the bottom, the status bar is displayed.

Click on any of the areas in the image below, or use the links provided in the text above, to learn more.

instant-wiki-md01

A. Menus

The application presents a main menu containing various options. Many of these options are only active when a project is open.

instant-wiki-md02

  • File menu

The File menu contains options that provide project file management.

instant-wiki-md03

The New file option starts a new project file.

The Open file option opens a saved project file.

The Close file option closes the currently open project file. If it has been modified, the user will be prompted to save the modifications.

The Save file option saves the currently open project file. If the file has not been named, the application prompts for a name.

The Save As file option saves the currently open project file using another name.

The Send e-mail option attaches the currently open projects in a new e-mail.

Most recent file list options. Up to 4 recently opened project files are retained here and can be quickly selected.

The Exit option closes the application. If a project file is open and has been modified, the user will be prompted to save the modifications.

  • Show menu

The view menu contains options that control the display of various application controls.

instant-wiki-md04

The Standard toolbox option toggles the display of the main toolbar.

The Window toolbar option toggles the display of the Window toolbar.

The Status bar option toggles the display of the status bar.

  • Analysis menu

The Analysis menu contains options that affect the analysis settings.

instant-wiki-md05

The Settings option displays the Analysis property page.

The Solve option starts the analysis of the selected members for the selected loading cases.

  • Reports menu

The reports menu contains the options that display the reports created during the analysis.

instant-wiki-md06

Each report type option opens another menu with more options, Text and Words.

instant-wiki-md07

In this manner, all report types produced during the analysis are available.

  • Display menu

The display menu contains options that control the display parameters of the currently active view window. These options are the exact counterparts of the buttons appearing on the view toolbar.

instant-wiki-md08

The Drawing option displays the draft drawing of the selected member in the active view window. This option is not available for the Member Design EC3 application.

The Solid 3D option displays the solid 3D model of the selected member in the active view window.

The Linked structure option displays the linked structure model in the active view window.

The Forces/Moments graph option displays the graphs of internal forces/moments for the selected member and loading case.

The Print drawing option is not available in the Member Design EC3.

The Export drawing option displays another menu with options to export the current drawing view to DXF or EMF drawing file. These options are not available for the Member Design EC3 application.

instant-wiki-md09

The Copy to Clipboard option displays another menu with options to copy the current drawing view to the Clipboard, either as a Drawing or as an Image.

instant-wiki-md10

The Side option displays another menu containing the various side views available for the selected member in the active view window.

instant-wiki-md11

The Zoom option displays another menu containing the zoom options available for the current view window.

instant-wiki-md12

The Elements option displays another menu containing options to display element data on a structure model, such as Node, Beam, Member names and Sections, as well as Supports.

instant-wiki-md13

  • Options menu

The Options menu contains various application options.

instant-wiki-md14

The Units option displays the units selection dialog.

The Interface language option displays another menu with options for all the supported interface languages, while also marking the currently active selection.

instant-wiki-md15

  • Window menu

The Window menu contains options for managing the view windows.

instant-wiki-md16

The New window option creates a new view window. The default view in a new window is the drawings view.

The Cascade option arranges all open view windows in a diagonal cascade.

The Tile horizontal option arranges all open view windows to cover all available space in the view windows area, starting from the upper left corner in rows.

The Tile vertical option arranges all open view windows to cover all available space in the view windows area, starting from the upper left corner in columns.

A list of all open view windows appears at the bottom of the menu and the active view window is marked. Selecting another window from the list makes it active and brings it to the foreground.

  • Help menu

The Help menu contains options that display help on using the application as well as information about the application version and the company that created it.

instant-wiki-md17

The Contents option displays this help file.

The Working examples option is not available for the Member Design EC3 application.

The About option displays a dialog that lists all application components and their respective version information.

B. Toolbars

The application displays two types of toolbars, the main toolbar, which appears at the upper part of the application window and the view toolbar, which appears at the upper part of each view window.

  • Main toolbar

instant-wiki-md18

The main toolbar contains groups of buttons that can handle the project file management and the view windows management. These buttons are presented below:

instant-wiki-md19 New file button. Use this button to start a new project file.

instant-wiki-md20 Open file button. Use this to open an existing project file.

instant-wiki-md21 Save file button. Use this to save the changes made to the current project file.

instant-wiki-md22 New window button. Creates a new view window. The default view in a new window is the drawings view.

instant-wiki-md23 Cascade button. Arranges all open view windows in a diagonal cascade.

instant-wiki-md24 Tile horizontal button. Arranges all open view windows to cover all available space in the view windows area, starting from the upper left corner in rows.

instant-wiki-md25 Tile vertical button. Arranges all open view windows to cover all available space in the view windows area, starting from the upper left corner in columns.

  • View toolbar

instant-wiki-md26

The view toolbar contains buttons that operate on the view window where it is located. The various buttons are presented below:

instant-wiki-md27 Solid 3D view. Use this button to display the solid 3D model of the member.
instant-wiki-md28 Linked structure view. Use this button to display the linked structure model.
instant-wiki-md29 Internal forces/moments graphs. Use this button to display graphs of the selected member and selected loading case internal forces/moments.
instant-wiki-md30 Reset view. Use this button to reset the current view to initial values of display angles and zoom level.
instant-wiki-md31 Front view. Use this button to set the window view to front.
instant-wiki-md32 Right side view. Use this button to set the window view to right side.
instant-wiki-md33 Top view. Use thisi button to set the window view to top.
instant-wiki-md34 Back view. Use this button to set the window view to back.
instant-wiki-md35 Left side view. Use this button to set the window view to left side.
instant-wiki-md36 Bottom view. Use this button to set the window view to bottom.
instant-wiki-md37 Define or display structure cuts.
instant-wiki-md38 Find node or beam on structure.
instant-wiki-md39 Reset zoom. Use this button to reset the zoom level.
instant-wiki-md40 Zoom in. Use this button to enlarge the view.
instant-wiki-md41 Zoom out. Use this button to revert to previous zoom levels.
instant-wiki-md42 Display graphs of internal forces for selected member and selected loading case. These buttons are enabled only in graphs display.
instant-wiki-md43 Display graphs of internal moments for selected member and selected loading case. These buttons are enabled only in graphs display.

C. Status bar

The status bar is located at the bottom of the application window. To the left of the bar text is displayed showing the application status or information about the object which the mouse is hovering over. To the right, the currently selected units are displayed. Double clicking on this area will display the Units selection dialog.

instant-wiki-md44

D. Property pages

In the property pages area, the following property pages tabs are displayed: Project, Members, Analysis.

In each property page, a property grid is contained, which displays data entries related to the selected page.

  • Project page

The Project page contains a property grid with the project data entries, such as file name, project name, engineer name and project data. The option to link the project to an existing solution is also here.

instant-wiki-md45

  • Members page

The Members page contains the project members tools, such as Add and Delete buttons as well as the table showing the members defined in the project which can be used to easily locate and edit a member’s data.

instant-wiki-md46

Immediately below the table, a property grid is displayed, showing all the selected member’s data.

At the bottom of the page, there is a list that displays messages about the members data status. These messages are of various types, which can be easily determined from the icon they are marked with. These icons are explained below:

instant-wiki-md47 Information message.
instant-wiki-md48 OK message.
instant-wiki-md49 Warning message.
instant-wiki-md50 Error message.

The messages are updated after each change the user makes to the selected member data.

  • Analysis page

The Analysis page contains a property grid with the analysis and reports options and a list of all defined members and loading cases, as well as the Analysis button. After selecting the members and loading cases that will be verified in the analysis and setting the various options, the Analysis button is activated and the user can start the analysis and design process.

instant-wiki-md51

The analysis options are as follows:

Option to select the safety factors that will be used during the analysis.

Option to select the language used in the creation of reports.

Option to display the report after succesfully completing the analysis.

Option to create a report only for the loading case that produces the worst ratios from all selected.

Members which have erroneous definitios will be displayed in gray color and will not be available for selection. Selection of multiple items is made easier with the buttons select/deselect all for members and loading cases.

When the Analysis button is pressed, the application performs the analysis and design for all selected members and loading cases and depending on the selected options, can then display a report of the results.

  • Loading cases

The Loading cases page contains various controls to display and manage the loading cases used in the project.

If the project is linked to a structure, the drop-down list control allows only to select from the loading cases available in the structure solution and the Add and Remove buttons are disabled.

In a stand-alone project, the Add and Remove buttons are enabled. The name of a loading case can be entered or edited in the drop-down list control. The new name is accepted as soon as the Enter key is pressed or the selection changes to another loading case.

instant-wiki-md52

The table Loading Cases Data displays the complete loading case internal forces/moments values for various points along the member, using the currently selected units, as shown in the column headers.

If the project is linked to a structure, the table data is read-only.

In a stand-alone project, the user can enter or edit the values in the table cells the loading case internal forces/moments values in the currently selected units.

  • Pages Buckling XY, XZ and Lateral-Torsional Buckling

The pages Buckling XY, XZ contain controls to define and and manage the buckling data for their respective planes. For every new member the program defines by default Translation constraints at the start and end node and considers the member as Non-Sway.

instant-wiki-md53

instant-wiki-md54

Adding a constraint is made easy by the presence of a list of nodes without constraints, as well as a group of constraint options where the user can select the default type of constraint to be applied on all new constraints. To apply a constraint on one or more nodes, the user can select the nodes from the “Nodes without constraints” list and then transfer them to the “List of constraints” using the [<] button to transfer only the selected nodes, orr the [<<] button to transfer all the nodes. If the user wants to remove constraints from one or more nodes, he must select them from the "List of constraints" and use the [>] button the selected nodes to transfer them to the “Nodes without constraints” list, or the [>>] button to transfer all the nodes.

Note: It is not possible to remove all constraints from a member. The application will keep at least one constraint and force that to a Rotation constraint, so that the buckling lengths can be computed correctly.

The user can select the constraint type between Translation, Rotation and value of n. At every change of a constraint type a current value of n is recalculated for the constraint, as wel as all buckling lengths of the member.

Specifically for the Lateral-Torsional Buckling page, the constraints definitions include K and Kw types which can be selected independently.

instant-wiki-md55

E. Property grid

  • Introduction

The property grid is a modern control in which various types of information can be displayed in a hierarchical fashion. The control displays two fields for each entry, on the left is the entry name field, such as “Date” and on the right, the entry value field, i.e. “1/1/2008”. Each entry value field can have a different data type i.e. text, number, date, but also display another control object, such as buttons, check boxes, drop-down lists etc.

instant-wiki-md56

Many entries can be grouped under a common heading and be collapsed to save space or expanded to be viewed or edited. The collapse/expansion is handled using the [-] and [+] buttons that appear before the grouping header entry, or with a double click on the grouping header entry, as can be seen in the image below.

instant-wiki-md57

  • Editing

The value field on the right of an entry can be edited using a left click of the mouse in the field area. After editing, the new value is stored using the Enter key or by selecting another entry. To abort the editing and avoid storing the new value, use the Esc key.

Various fields may perform value verification and may reject values that are considered illegal, such as member length or b * Anet less than zero. When a new value is rejected, the previous value is automatically restored.

F. View windows

The application can display many views of the selected member. Each view appears in a separate window, in the view windows area. Each window has its own view toolbar. This means that each view can be set to any of the available view modes (solid 3D, linked structure or internal forces/moments graphs) as well as rotation and zoom, independently of the other views.

instant-wiki-md58

A new view can be created by clicking the New window button on the main toolbar, or by using the same option in the Window menu. To arrange the existing windows, use the buttons Cascade or Tile horizontal, Tile vertical in the main toolbar, or the same options found in the Window menu.

Note : If all view windows are closed, the project file is also closed.

G. Units

The units of values entered in various entries, can be set using the menu Options -> Units, or using a double click on the status bar, in the area where the currently selected units are displayed. Both these options will display the units selection dialog, as shown below.

instant-wiki-md59

After changing the selected units and pressing the OK button, all the values displayed in the property grid and the property pages are updated to display using the new current units.

H. Language

In the current version, the application supports the following languages:

  • Greek
  • English
  • Romanian

The language interface can be selected from the Options menu -> Interface language.

Independently of the currently selected interface language, the reports can be produced in any of the supported languages. The report language selection can be found in the Analysis tab page.

[next]